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Editorial

* Récompenses et Nouveautés

Méme si cette année NOVACAD n’a pas regu le prix de distributeur européen de l'année
2007/2008, laissant au distributeur anglais Quadra Solutions le titre (plus d‘informations
http://www.zuken.com/news/press0806 cadstar reseller of the%?20year.asp) , nous sommes fiers
de notre place dans un marché trés concurrentiel.

CADSTAR lui méme a été multi récompensé !

Tout d’abord E&E (Elektronik & Entwicklung) a décerné un prix
d’excellence a CADSTAR pour sa simplicité d‘utilisation et sa
CADStar-Express compatibilité avec d’autres logiciels de conception/fabrication. E&E a
7uken en effet récemment placé CADSTAR Express qui est la version

téléchargeable a la deuxieme place dans la catégorie des outils et
logiciels de conception (plus d'informations http://www.eue24.net).

Puis EG3 a décerné son « Tech Choice Award » a CADSTAR version 10
dans la catégorie Outils et FPGA. Avec plus de 42 000 abonnés, EG3 est un
portail de systemes embarqués de niveau mondial. A travers son concours
annuel, EG3 récompense les outils récents les plus performants ainsi que ceux

qui proposent des solutions de conception pratiques. Les points principaux ayant “;—*.\-{

permis a CADSTAR 10 d’étre un des vainqueurs sont une gestion de conception
améliorée pour les développements «justes du premier coup», des améliorations
en matiére de convivialité, un module compagnon particulier pour l'intégration TeCh
embarquée des FPGA ainsi que le lancement de E3.logic pour CADSTAR - qui -
constitue une solution frontale alternative qui permet a CADSTAR d’intégrer E3 ChO|Ce
Series, l’environnement de conception de logiciel électrique de Zuken (plus :
d’information sur http://www.eg3.com/). :

Apres les récompenses les nouveautés !

Zuken prépare l'avenir de ses produits toute gamme confondue
avec l'annonce du nouveau routeur révolutionnaire le « Dragon
Router ». Cet outil de routage a module d’apprentissage a pour but de
réconcilier les partisans du routage manuel avec le routage
automatique. Issu de lI'expérience des ingénieurs de routage de Zuken
au Japon, le Dragon Router se veut vraiment un outil intelligent et
performant dans les applications actuelles de routage aux contraintes
(High Speed, Paires Différentielles, Bus DDR, etc). Le Dragon Router
sera disponible dés cet été sur CR5000 et trés prochainement sur
CADSTAR.

Plus d’informations :
http://www.zuken.com/news/press0805 dragon router launch.asp.
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CADSTAR 10 : La gestion des bibliotheques ...

La version 10 de CADSTAR introduit de nombreuses nouveautés autour de la gestion de vos
bibliothéques. Ces nouveautés ont pour but d’accélérer I'utilisation, d'optimiser et de sécuriser vos
données.

* Intégration du Parts dans les études schématiques et PCB

Pour faciliter la gestion des études schématiques et PCB, la version 10 intégre dans la structure
méme des fichiers SCM et PCB les informations contenues dans les fichiers Parts. Toutes les
informations sont donc maintenant incluses dans ces fichiers dés que vous avez fait une commande
Add Part...

Cela signifie que vos fichiers sont désormais autonomes des bibliothéques. Et donc vous n'avez
plus besoin de celles-ci lors des commandes comme Item Properties, Report Parts List, les
permutations de portes et de broches, les transferts vers le Route Editor, et les ECO Updates
(attention la bibliothéque des composants PCB est toujours utile dans ce dernier cas pour |I'ajout de
nouveaux composants dans I'étude).

Cette intégration implique que lors de la mise a jour de Parts dans la bibliothéque (par exemple
la modification du type de composant PCB), il faudra impérativement réaliser un Reload From
Library dans la schématique sinon la modification ne sera pas prise en compte.

L'un des avantages majeurs de cette nouveauté est de pouvoir facilement recréer une
bibliothéque de Parts depuis un fichier SCM ou PCB. Pour réaliser cette opération, vous trouverez
dans la commande File > File Export, le format de sortie CADSTAR Part Library.

* Gestion de version d’éléments de bibliothéques

Libram Yersion Mumbers

Afin de gérer au mieux |’évolution de vos bibliothéques vis a vis de vos
études, les 3 éléments des bibliothéques CADSTAR (symbole schématique, v Automalic ersion Increment
composant PCB et Parts) possédent aujourd’hui un indice de version. Cet
indice est wun chiffre qui va s'incrémenter automatiquement OU || pisplayVersionWarring Dislags
manuellement a chaque modification d’'un de ces éléments. Ce choix est
proposé dans le menu Tools > Options.

Parts

D efiritions

Part Name |Number |Descripti0n /|Versi0n ‘l}gﬁnition |SPICE

L'indice est placé dans les propriétés des

FST22053MTC DUAL 41 MULTIPLEXER/DEMULTIPLEKE 1 FAT22253MTC symboles et des composants (File > Properties
FST32253MT X DUAL &1 MULTIPLEXER/DEMULTIPLENE 1 FS|r3zesam T - -
FSTI2AMTC BEIT BUS SWATCH 5 FeTa2a4MTC ou dans le menu Properties du L'br_ary
FSTa24AMTE BBIT BUIS SWITCH 2 F9TaRMMICX Manager) et dans la nouvelle colonne Version
FaTa2aaMTE BEITBLS SwiTCH 2 smaMic )| pour les Parts (voir ci-contre).

A partir de cet indice, vous allez pouvoir analyser les éléments qui ne seraient pas a jour avec

ceux contenus dans les bibliothéeques. Le menu Item
Properties affiche la version actuelle dans I'étude et la version
de la bibliothéque (voir ci-contre).

Le menu Reload From Library (menu Actions), permet
lui d’analyser rapidement les éléments qui ne sont pas a jour
(option Select Out of Date). Deux colonnes Design Version
Number et Library Version Number apparaissent. Si les
indices sont en rouges (version bibliothéque supérieur a version
étude) ou en bleus (version étude supérieur a version
bibliothéque) c’est qu’il y a une différence d’indice. Number:

Un rapport est également disponible pour réaliser une | pesciption H2F TRS Metal Orids Fim
analyse des éléments entre I'étude et la bibliothéque. Dans le | wubrayfat: [GtandadDiscretedio
menu Tools > Reports > Versionning, vous pouvez obtenir 1
un rapport complet sur tous les éléments ou uniquement les 2

Component Definition Details

Library Path: | {Standard}peh.lib

Height:
Design Yersion:

Library Version:

Part Details

Design Yersion:

Libramn Version:

éléments « out of date » (choix par le bouton Options).

Il est également possible de réaliser des rapports avec le Report Manager incluant cet indice.
Vous avez méme un champ spécifique « ... Library Version Comparaison » qui peut faire I'analyse
directement en indiquant « Out of date » dans le cas d'un élément non a jour par rapport a sa
version bibliothéque.
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A noter que pour synchroniser automatiquement une bibliothéque de symboles ou de
composants existante a la version « 1 » par exemple, vous pouvez utiliser la fonction Versions dans
le Library Manager. Cette fonction permet de placer le numéro de version souhaité sur les éléments
sélectionnés. Vous pouvez réaliser cette opération uniquement sur les éléments ayant un numéro de
version spécifique (indiqué dans Old Version), ou bien pour tous les éléments quelque soit leurs
numéros de version (option All Versions cochée). Le choix du nouveau numéro de version est a
indiquer dans New Version .

* Attributs pour les symboles et les composants PCB

Jusqu’a présent seul les Parts possédaient des attributs. Avec la version 10, vous pouvez ajouter
des attributs aux symboles schématiques et aux composants PCB. L'intérét de ces attributs est de
définir des attributs qui personnalisent au mieux I’élément de bibliothéque. Par exemple : «Créé par»,
«Date de création», «Modifié par», «Date de derniére modification», «Vérifié par», «Date de
vérification», etc.

[ Mimared (®) Selection [™] =
Les noms et les valeurs des attributs sont sty =
totalement libres. Le type de ces nouveaux ——
attributs est « Symbol Definition ». Pour les |

ajouter aux éléments, utilisez le menu File >
Properties ou le bouton Properties du Library
Manager.

Ils seront accessibles dans le menu Item
Properties dans le bouton Attributes (voir ci-
contre) et ils pourront également étre présents
dans les rapports du Report Generator et dans
les rapports de versions. Dans ce type de rapport,

Reference:
Alternate:

Library Path:

Pait Details
Name:
Number:
Description:

ibeon Dol

Pitch.5
{Standard}hpch. lib

Height:
Diesign Version: 2

Libram WVersion: 2

R12-2%-TR4

118 Thou

12R TR4 Metal Ovide Film 23

10 tandard i Misrrats b

Attribute VWalue: [Read Only)
BOB

;—}

vous allez choisir les attributs que vous souhaitez voir apparaitre dans le rapport (menu Options ci-
dessous).

Yaltage
W atkage

x| & x| -
Repart Target Cptions .
[#]¥iew Repart ) all components () 0wt of date Uersion R
[ Pint Repon (pesign [urary CADSTAR Design Editor
Part/ Camponent Attributes skt Definition Attributes
(e Rz Tl Chnoeliichioncy Eloc_type 7 Design: C:hvcswin18ySelf Teach\Chapter
riFacturer tolerance pesi Tit1
- wer_diss violtage esign Title:

[ L3 ] [ Cancel ][ Help (][me”&' e wattage Post Processing Ther Design

Date:
Time:

lundi 9 juin 2088
14:46

* Part RBK2-2%-TRA4
Part Uersion Humber:
Design: 1
Library: 1
omponent Definition: TR4 (Pitch.5)
Component Uersion Humber:

oK [ Cancel ] [ Help

BOB
Library: JOHH

A noter que pour faciliter la mise a jour de ces attributs ainsi que vérifier I'indice de version,
vous pouvez demander que le menu Properties s’affiche automatiquement lors de la sauvegarde du
symbole ou du composant aprés modification. Cette option se trouve dans le menu Tools > Options
dans la section Library Version Numbers (voir image en début de chapitre). Dans cette section
vous pouvez également valider la génération d’avertissement lors de la manipulation des indices de
version a la main (exemple : rétrogradation d’indice, suppression d‘indice,...).

L'intérét des ces attributs est d’obtenir une tracabilité des éléments et ainsi pouvoir facilement
repérer dans une étude existante les obsolescences, suivre les versions et gérer les mises a jours
nécessaires.

Avec l'intégration des informations du parts dans les fichiers études, les indices de version, les
attributs symboles/composants, la version 10 permet de mieux gérer ses éléments de bibliothéques
depuis leur création et durant leur utilisation. Avec les indices vous pouvez facilement effectuer les
mises a jours et avec les attributs obtenir des rapports pour mieux tracer les révisions des symboles
ou des composants.
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Astuces

En version 10, I'onglet «Function Keys» du dialogue «Tools > Customise» est remplacé par
un onglet «Keyboard».

Cet onglet permet non seulement d’assigner des fonctions aux clés F1 a F12 et a la clé du
milieu de la souris mais aussi a toutes les combinaisons de touches du clavier alphanumérique
+ touches shift, alt ou ctrl, aux touches étendues (Insert, Delete, Home, End, Page Up, Page
Down) avec ou sans les touches shift, alt ou ctrl.

Si une combinaison de touches est déja assignée a une commande ou une macro commande,
elle apparait dans I'espace «Shortcuts for selected command».

Pour assigner une commande ou une macro commande a un raccourci, sélectionnez la
commande ou la macro dans les colonnes de gauche, puis placez-vous dans le champ «Press new
shortcut key(s)», puis entrez au clavier la combinaison de touches souhaitée, validez par «Assign>.

Un avertissement vous prévient si un raccourci est déja utilisé par ailleurs ou si il est
«(unassigned) ».

Commands | Teolbars | Macros Toolbar | Keyboard

M View File B =1

Commands Shorteuts for selected command:
ConnectionCheck ¥ CTRL+A <Selectnll> ~
- CTRL+C <Copy> 1
Connectionlength
poepePour ’ |:| it P
Copy = CTRL+E <Execute>
CopyToBitmap Press new shortcut keyfsk CTRL+F {Find>
CreatehlenShest F1 <HelpCurrentToolHelp>
Cre.ate/ariantSpmbol ‘ETRL+MAJ+V ‘ [ - ] F2 <Hove>
Euslomicz Fa <Rotate>
CutBlock ~ Sharteut currently assigned to Fh4 <DoubleClick>
= . CTRL+F4 <CloseWindow>
Macios: [unassigned] ALT+F4 <Exit> =
Add_layer A Defaul Key Fi F5 <EditSegment>
Bot 3 EEA=DIAID F6 <ChangeRoutelayer>
GO 1ram C:toswin DN serdefaults key E] F7 <Windoulove>
gloﬂﬂmﬂ F8 <Refresh>
il : ;
G2l b [ Impart. . ] [ Expait... ] [ Report. € :IE#:'F:: iz;gr‘;ggg"uevn
F9 <ZoonInfAtCursor>
F18 <ZoomOutAtCursor>
F11 <Rarnnnarcty s
< 3

]

[ Close I [SaveAs l [ Frit

Il est possible d'assigner une commande ou une macro commande a plusieurs raccourcis.

Un rapport des raccourcis peut étre obtenu par la touche «Report...».

Il est possible d’exporter ou d'importer («Export.../Import...») des jeux de raccourcis (fichier
.key) dans le cas d’une utilisation multi-utilisateurs.

Autd$Vue.

Astuce cnerpriseVisualization *

Il est possible avec Autovue de réaliser de nombreuses intégrations pour faciliter votre
utilisation quotidienne du logiciel. Ces automatisations sont réalisées soit par des lignes de
commandes, soit par des scripts soit méme des API (application program interface).

Pour les scripts, a son lancement, AutoVue peut exécuter automatiquement un fichier de
commandes. Ce script de commandes permet d'exécuter des opérations telles que la désactivation de
menus, la modification des options de configuration, la manipulation de vues, l'impression ou la
conversion de documents. Les options disponibles sont
décrites dans le fichier AvAdministratorGuide.pdf. 2 scriptfile.txt - Bloc-notes

Exemple : Si vous souhaitez configurer Autovue | Fichier Edtion Format affichage

A i i i i A WIEW FILEMAME
pour realiser une impression en portrait, en échelle |Jyi& FILEME @ @ artonce

automatique et avec un texte en surimpression "document |FRINT OPTION SCALE=FIT .
FPRINT OPTION WATERMAREK ~DOCUMENT MOM DEFINITIF

non définitif" du fichier "Filename", créez un fichier texte |
scriptfile.txt contenant les lignes ci-contre.

Puis exécutez la ligne de commande suivante :
avwin -s scriptfile.txt

Retrouver plus d’informations sur le web : www.novacad.fr - Rédaction et Mise en page : Robert Gianotti
Toutes les marques ou produits cités sont des marques déposées par leur propriétaire respectif. © JUIN 2008 NOVACAD
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